template->_php_include(): File ./../includes/nav.inc.php does not exist or is empty

segfault on 1.3

Helpful information for people wanting to run dedicated Dystopia servers

Moderator: Forum Moderators

segfault on 1.3

Postby Kissaki » Wed Sep 15, 2010 8:47 pm

the dystopia server will segfault for me, on my x64 Debian server; TF2 does work

Code: Select all
pub/orangebox# ./srcds_i486 -console -game dystopia -port 27020 +map dys_vaccine

Console initialized.
Segmentation fault


Where pub is the folder I installed -game orangebox into, and pub/orangebox the folder I installed -game dystopia into.

I also now tried it exactly with the 2 commands on the wiki page, using that folder structure (apart from the user)
http://www.dystopia-game.com/wiki/index ... ough#Linux
still, same problem; ./srcds_run -game dystopia will die with a segfault.
Kissaki
Blank Load Out
 
Posts: 7
Joined: Fri Jan 16, 2009 8:28 pm

Re: segfault on 1.3

Postby Shaft 6 » Thu Sep 16, 2010 5:31 am

me to. did you move your 1.2 dystopia and hl2 folders to the orangebox folder?

Code: Select all
philip@philip-mythbuntu:~/srcds_l/orangebox$ ./srcds_run -game dystopia -ip 192.168.1.2 -port 27015 +map dys_vaccine -debug
Auto detecting CPU
Using default binary: ./srcds_linux
Enabling debug mode
Server will auto-restart if there is a crash.
Using breakpad minidump system
Using breakpad crash handler

Console initialized.
Segmentation fault (core dumped)
BFD: Warning: /home/philip/srcds_l/orangebox/core is truncated: expected core file size >= 42680320, found: 12324864.
Cannot access memory at address 0xf77958f0
Cannot access memory at address 0xffc618dc
/home/philip/srcds_l/orangebox/debug.cmds:4: Error in sourced command file:
Cannot access memory at address 0xf77958f0
email debug.log to linux@valvesoftware.com
Thu Sep 16 22:29:21 NZST 2010: Server restart in 10 seconds
Thu Sep 16 22:29:23 NZST 2010: Server Quit


Code: Select all
----------------------------------------------
CRASH: Thu Sep 16 22:29:20 NZST 2010
Start Line: ./srcds_linux -game dystopia -ip 192.168.1.2 -port 27015 +map dys_vaccine -debug
[New Thread 3756]
#0  0x00000000 in ?? ()
No symbol table info available.
eax            0xf70042f8   -150977800
ecx            0x4e   78
edx            0x0   0
ebx            0xf6f98038   -151420872
esp            0xffc618dc   0xffc618dc
ebp            0xffc61958   0xffc61958
esi            0x0   0
edi            0x81645a0   135677344
eip            0x0   0
eflags         0x10202   [ IF RF ]
cs             0x23   35
ss             0x2b   43
ds             0x2b   43
es             0x2b   43
fs             0x0   0
gs             0x63   99
End of Source crash report
----------------------------------------------
Shaft 6
Blank Load Out
 
Posts: 4
Joined: Sun Dec 09, 2007 12:20 am
Location: New Zealand

Re: segfault on 1.3

Postby Fruchtzwerg » Thu Sep 16, 2010 5:53 am

You can't mix HL2 and Orange Box engine files by moving it. It will not work, different engines...
Fruchtzwerg
Blank Load Out
 
Posts: 4
Joined: Wed Sep 15, 2010 11:43 am

Re: segfault on 1.3

Postby Atomy » Thu Sep 16, 2010 5:30 pm

make sure u guys arent using orangebox of tf2, since orangebox != orangebox - the mods got a different version of orangebox(-game orangebox) then cssbeta and tf2 uses

in your orangebox/bin/ dir should be, engine_amd.so, engine_i486.so, engine_i686.so, afaik the tf2 orangebox just has engine.so in its orangebox/bin/
User avatar
Atomy
Puny Human staff
 
Posts: 444
Joined: Thu Jul 05, 2007 10:31 am
Location: Germany

Re: segfault on 1.3

Postby Kissaki » Thu Sep 16, 2010 6:45 pm

Atomy wrote:make sure u guys arent using orangebox of tf2, since orangebox != orangebox - the mods got a different version of orangebox(-game orangebox) then cssbeta and tf2 uses

As I said I followed the wiki.
I ran those 2 update commands, orangebox and dystopia,
and then tried to run it from within the orangebox folder, which segfaulted.

in your orangebox/bin/ dir should be, engine_amd.so, engine_i486.so, engine_i686.so, afaik the tf2 orangebox just has engine.so in its orangebox/bin/

Indeed. It is.
Kissaki
Blank Load Out
 
Posts: 7
Joined: Fri Jan 16, 2009 8:28 pm

Re: segfault on 1.3

Postby !Boot » Thu Jan 27, 2011 1:00 pm

I also receive a segmentation fault when starting srcds, after following the wiki article. Did anybody find a fix to this?

Code: Select all
./srcds_run -game dystopia -ip 192.168.0.254 -port 27015 +map dys_vaccine
Auto detecting CPU
Using SSE2 Optimised binary.
Server will auto-restart if there is a crash.

Console initialized.
Segmentation fault
Add "-debug" to the ./srcds_run command line to generate a debug.log to help with solving this problem
Thu Jan 27 17:53:42 GMT 2011: Server restart in 10 seconds
!Boot
PHAN
PHAN
 
Posts: 10
Joined: Thu Apr 16, 2009 10:48 am

Re: segfault on 1.3

Postby Atomy » Fri Jan 28, 2011 9:04 am

I've been getting them randomly sometimes, but yeah cant help here that much, you could try debugging with the help of gdb, retry it to see if its happens randomly.
User avatar
Atomy
Puny Human staff
 
Posts: 444
Joined: Thu Jul 05, 2007 10:31 am
Location: Germany

Re: segfault on 1.3

Postby Atomy » Fri Feb 04, 2011 11:10 am

when you are still trying, here's another hint, go into the orangebox/ dir of your server installation, do a ldd dystopia/bin/server_i486.so and look for any "=> not found" errors, we dont really depend on anything but maybe you are missing some libs on your machine (ignore the tier0, vsdlib, steam_api stuff, its in orangebox/bin and will be loaded on server start)

let me know if that helps!
User avatar
Atomy
Puny Human staff
 
Posts: 444
Joined: Thu Jul 05, 2007 10:31 am
Location: Germany

Re: segfault on 1.3

Postby Symphona » Wed Apr 27, 2011 6:08 am

I have had this problem and followed some vaguely related advice in a another thread which pointed out that 1) the two updates should be run in a certain order and 2) you can use a -verify_all tag on the orangbox install to check it.

After running the two in order, then running the verify seperately, it downloaded a lot of different files, and the game now runs seamlessly. It might be an idea to update the wiki instructions? I know I am not the only one to have seg faults when following those instructions

Thanks, Sym
Symphona
Blank Load Out
 
Posts: 1
Joined: Tue Apr 26, 2011 9:24 am

Re: segfault on 1.3

Postby Atomy » Thu Apr 28, 2011 9:42 am

I think I tried the wiki steps a while ago on a clean box and it worked, the order is indeed important since the game "dystopia" overwrites some orangebox files with wrong versions of them
User avatar
Atomy
Puny Human staff
 
Posts: 444
Joined: Thu Jul 05, 2007 10:31 am
Location: Germany


Return to Dystopia Server Administrators

Who is online

Users browsing this forum: No registered users and 2 guests

cron