template->_php_include(): File ./../includes/nav.inc.php does not exist or is empty

Missing vmt file

Everything from maps to future workshop content! Here is the place to talk about it.

Moderator: Forum Moderators

Missing vmt file

Postby Napk1nz » Tue Dec 02, 2014 1:15 pm

I have a problem, I started creating basic swords and when I try to load the sword in game it gives me this error message

2014-12-02_00001.jpg
screenshot of the error
User avatar
Napk1nz
Blank Load Out
 
Posts: 3
Joined: Tue Dec 02, 2014 12:42 pm

Re: Missing vmt file

Postby fug » Wed Dec 03, 2014 3:22 pm

Hello, it seems there is an issue recognising what materials you've used for your sword.

Could paste the .vmt text using notepad and also the first 20 lines of your reference .smd (again opened with notepad).

Thanks
Image
User avatar
fug
Puny Human staff
 
Posts: 285
Joined: Wed Feb 23, 2011 5:51 am

Re: Missing vmt file

Postby Napk1nz » Tue Dec 09, 2014 1:22 pm

(smd_mdl)
________________
version 1
nodes
0 "world1" -1
1 "RealDWG_Shape_Rep" -1
2 "Sword" -1
3 "Sword_grip" -1
end
skeleton
time 0
0 0.000000 0.000000 0.000000 1.570796 -0.000000 0.000000
1 0.000000 0.000000 0.000000 1.570796 -0.000000 0.000000
2 0.000000 -15.674618 0.000000 -0.001745 -1.570796 0.000000
3 0.000000 0.000000 0.000000 1.570796 -0.000000 -1.570796
end
triangles
BoStaff.tif
2 0.049744 -45.953186 0.315740 0.453990 -0.000792 0.891007 0.375000 0.312500 1 3 1.000000
2 0.142292 -45.953346 0.268585 0.453990 -0.000792 0.891007 0.387500 0.312500 1 3 1.000000
2 0.247984 14.603420 0.268585 0.453990 -0.000792 0.891007 0.387500 0.688440 1 3 1.000000
BoStaff.tif
----
----
(vmt)
________________
"VertexLitGeneric"
{
"$model" 1
"$nocull" 1
"$surfaceprop" "Metal"

$basetexture "models/76561198049957416/BoStaff/BoStaff"

$bumpmap "models/76561198049957416/BoStaff/BoStaff_norm"
"$envmap" "env_cubemap"
"$normalmapalphaenvmapmask" 1
"$envmapsaturation" "0.4"
"$envmapcontrast" "1"
"$envmaptint" "[0.4 0.4 0.4]"

"$phong" 1
$FORCEPHONG 1
"$phongalbedotint" "1"
"$phongfresnelranges" "[0.5 1 3]"
"$phongexponent" 100
"$phongexponenttexture" "models/76561198049957416/BoStaff/BoStaff_exp"
"$lightwarptexture" "models/shared/lightwarp_darken"
"$phongwarptexture" "models/shared/phongwarp_metallic1"
"$phongtint" "[0.6 0.6 0.6]"
"$phongboost" "110"
"$rimlight" "1"
"$rimlightboost" "4"
$rimlightexponent 1000


$CHARGEPASSENABLED 1
$CHARGENOISETEXTURE "Engine/noise-blur-256x256"
//$CHARGEAMOUNT 0.3
$CHARGEFRESNELPULSEENABLED 1

$CHARGESPECULARBOOST "1"
$CHARGEGLOWBOOST "1"
$CHARGEPULSESPEED "8"
$CHARGEDARKENMAXINNER "0.8"
$CHARGEDARKENMAXOUTER "1"

$CHARGENOISEAMOUNT "0.75"
$CHARGENOISEBASESCALE "0.1"
$CHARGENOISEFLOWSCALE "0.005"
$CHARGENOISEFLOWSPEED "25.0"

$CHARGEFRESNELPOWERMIN "0.1"
$CHARGEFRESNELPOWERMAX "4"
$CHARGEFRESNELAMOUNTMIN "0.4"
$CHARGEFRESNELAMOUNTMAX "2"
$CHARGEFRESNELNOISESPEED "4" //"20"
$CHARGEFRESNELNOISESCALE "30" //0.1
$CHARGEFRESNELNOISEDISTANCE "60"

$CHARGEMODULATEBYFRESNEL 1

//"$CHARGETEXTURE"
//"$CHARGENORMALTEXTURE"

$CHARGEAXISFWD "[1 0 0]"
$CHARGEAXISLEFT "[0 0 1]"
$CHARGEAXISUP "[0 -1 0]"
"$PHONGEXPONENTTINTMASKENABLE" 1

"Proxies"
{
"PlayerTint"
{
}
"PlayerChargeEffect"
{
"resultvar" "$chargeamount"
}
"PlayerChargeColor"
{
"resultvar" "$chargeColor"
}
}
}
User avatar
Napk1nz
Blank Load Out
 
Posts: 3
Joined: Tue Dec 02, 2014 12:42 pm

Re: Missing vmt file

Postby Napk1nz » Wed Dec 10, 2014 2:54 pm

Never mind, I realize that I didn't place a couple files into the material sub folder of the main workshop folder. but thanks anyways
User avatar
Napk1nz
Blank Load Out
 
Posts: 3
Joined: Tue Dec 02, 2014 12:42 pm


Return to 3rd party development

Who is online

Users browsing this forum: No registered users and 1 guest

cron